News from ‘3rd Line’ 23rd January 2021

While still unable to get to the equipment life goes on with repairs to spares stock and innovation of test equipment continues from our 3rd Line set-up – Pete’s spare room! Here is the test bench followed by an update on what has been happening:

Disk trays:
I now have a number of SD and Micro SD cards to use with the SCSI disk emulators as opposed to hard drives and I‘ve loaded two SD cards with the Disk Utilities (test software). Both our disk trays are serviceable but only after sorting a couple of problems. The disk tray from the LCP loaded software from the drive OK but the tape drive appeared to be U/S. Long story cut short, the fault was not the drive but the controller (MS221). The MS221 in question was checked before but when I read the label on this card it read ‘not tested with tape drive’! Sorting out the disk trays gave me the chance to test a spare Archive 2150L tape drive, this spare drive is brand new and in original packaging, bought of eBay a while back. The drive was tested with loading software etc. and it ran without errors. Sometimes I struggle to get a tape read but this ‘new’ drive ran faultlessly. Perhaps problems are caused by old tapes and wear in old drives. Attached photo is my Argus 700 test bench set up for loading software, running test software and using the ME159 (Control and Monitor Console) shown here.

ME147 1MB Memory Cards
We have some U/S ME147 cards and trying to test these using the test program usually causes the both parity error LED’s on the cards to come on at one stage or another; the LED’s indicate parity errors on data being read and written. The following text document shows a typical report from a U/S card, a line from the report is:

7XME100A/3 Rel 9 Iss 5
Memory Test
Power Off test ?
Parity fail, VMR = #014603, Aux. VMR = #000200
Address #0, Contents = #042602, Test 0No
Full testing required ? No
Soak test ? No
to block = 31
Any more memory ? No
No. of errors per block with printout = 1
Go ? Yes
Testing 8k blocks: 4 to 31,
Address #120267, Read #, Expect #, Test
Address #142547, Read #, Expect #, Test
Parity fail, VMR = #034403, Aux. VMR = #000200
Address #164647, Contents = #000000, Test 16
Parity fail, VMR = #074403, Aux. VMR = #000200
Address #366457, Contents = #000000, Test 16
Address #413607, Read #052124, Expect #052525, Test 16
Address #420657, Read #052124, Expect #052525, Test 16
Memory block 2 not fitted

To give some idea of the complexity of these memory boards, which comprise a mother and daughter board here are the component layouts of the two which fit together in a sandwich arrangement with AMP conectors in between.

You would think it was a straight forward task to use the ME159 (Control and Monitor Console) to write data to the identified address on the ME147 and then read it back to see if it’s the same (I can do this). Unfortunately when checking the address in the line above with the ME159 it doesn’t give the error indicated by the test software, it reads and writes data without error! In every case of an identified error I’ve never been able to replicate the data error using the ME159. I also suspect that the mains supply I have is not exactly noise free so possibly causing random data errors.

All the best
Pete

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.